Archive for April, 2010

Monitoring jaringan dengan menggunakan The Dude

Mau ijin buat dokumentasi sederhana menggunakan The Dude nih… Maaf kalau menyebut merek selain Mikrotik dan seluruh varian nya.

Pendahuluan

Software aplikasi monitoring jaringan The Dude menurut saya pribadi merupakan salah satu yang terbaik selain itu gratis. Mengapa saya sebut terbaik ? tak lain adalah saat saya sendiri melakukan proses utak-utik di beberapa pengesetan dalam 2 minggu terakhir ini. SNMP (Simple Network Monitoring Protocol) sudah menjadi sebuah standar mutlak untuk peralatan perangkat jaringan, apakah itu yang perangkat yang berharga murah ataupun mahal. Buat teman-teman yang pernah baca referensi artikel mengenai pembahasan SNMP pasti pernah mengalami betapa frustasinya, karena memang dibingungkan oleh istilah-istilah yang sulit dipahami.

Jadi apa yang bisa kita manfaatkan dari protokol SNMP untuk kita ketahui sehingga dapat dimanfaatkan untuk memantau jaringan kita ?hmmm.. Pertama kita harus mengetahui SNMP Community nya terlebih dahulu, beberapa perangkat mengesetnya secara default dengan pengisian public apabila berbeda sesuaikan dengan perangkat milik anda. Apabila anda sudah membuat map jaringan sederhana seperti dibawah ini misalnya :

Snmpwalk

Nah bagaimana memanfaatkan informasi SNMP yang sudah ada pada masing-masing perangkat ? jawabannya adalah menggunakan snmpwalk. Snmpwalk merupakan utilitas yang terintegrasi dari SNMP, untuk pemakaian pada The Dude klik kanan menu Tools snmpwalk pada perangkat yang ingin anda ketahui informasi SNMP nya. Pada gambar 2 dibawah ini merupakan informasi yang dapat kita ketahui dari perangkat radio wireless motorola canopy, selain kita bisa mengetahuinya dari menu web tentunya. Tampak informasi disini bahwa kekuatan sinyal nya adalah -42 dBm dan sedang dalam posisi terkoneksi dengan perangkat yang lain (REGISTERED), juga informasi mac address nya kelihatan bukan ?

Apakah anda sudah mulai tertarik untuk mendalami lebih jauh tentang manfaat penggunaan SNMP ?mari kita lanjutkan kembali tentang bagaimana pengesetan SNMP di The Dude. Klik pada tombol Settings  pilih pada Tab SNMP. Untuk menambahkan Community SNMP yang baru klik tombol + (plus), anda harus mengetahui SNMP Community pada perangkat misalkan saja public selanjutnya adalah versi SNMP nya biasanya pilih versi 2c

Langkah selanjutnya adalah menambahkannya pada properties pengesetan The Dude. Ubah pada menu SNMP Profile dan pilih SNMP Community yang sesuai dengan perangkat jaringan yang akan kita baca informasi SNMP nya.

This image has been resized. Click this bar to view the full image. The original image is sized 780×401.

MIB (Management Information Base)

Nah sekarang adalah bagian menariknya bagaimana sih menggunakan The Dude untuk menampilkan informasi SNMP yang ada pada perangkat jaringan kita. Pada menu apabila kita klik mouse sebelah kanan akan tampil menu Appearance disinilah awal kesenangan saya, informasi apa sajakah yang ingin kita tampilkan. Sebelum beranjak pada menu ini, saya akan menerangkan apa itu OID SNMP. OID SNMP seperti yang saya pahami adalah merupakan informasi terstruktur dari sebuah database SNMP yaitu MIB. Apabila anda pernah membuka menu Mib Nodes pada The Dude pastinya anda sudah sedikit mempunyai gambaran tentang bagaimana cara pemakaian nya.

Pada Mib Nodes terdapat berbagai macam file yang berfungsi untuk menampilkan informasi-informasi secara umum pada perangkat jaringan seperti SysName, SysContact, SysLocation, Uptime, dll tambahan pula pada instalasi The Dude secara default kita sudah bisa membaca beberapa perangkat jaringan bermerek seperti CISCO, ORINOCO, MOTOROLA CANOPY, TRANGO, ALVARION dan MIKROTIKnah bagaimanakah apabila perangkat yang ingin kita pantau tersebut belum ada pada Mib Nodes nya The Dude ? Gampang…. Tinggal kita upload saja file MIB yang berupa file teks (TXT) perangkat jaringan tersebut.

Tadi saya sebutkan bahwa OID SNMP mirip dengan sebuah database terstruktur bukan nah mengapa bisa disebut demikian ?karena secara fungsinya mirip dengan sebuah folder dan file yang ditata sedemikian rupa setidaknya itulah pemahaman saya. Sebuah contoh misalnya adalah OID SNMP untuk SysContact, SysLocation, SysName pastinya berbeda dong ?kalau diterjemahkan maka akan muncul menyerupai sebuah deretan angka-angka seperti 1.3.6.1.2.1.2.4.0, 1.3.6.1.2.1.2.6.0, 1.3.6.1.2.1.2.5.0 lho angka apa pula ini ? jadi tambah bingung nih…. Nah beginilah kalau menyebutkan secara angka, tetapi apabila menyebutkan dengan sebuah keterangan penuh akan seperti ini

Iso — 1
- Anonymous — 2
- Org — 3
- dod — 6
- Internet — 1
- Directory — 1
- Experimental — 3
- mgmt — 2
- mib-2 –1

|
|
|
|
|
|
- system –1
SysContact –4
SysLocation –6
SysName –5

Bisa pula dengan menyebutkan nya seperti dibawah ini

iso.org.dod.internet.mgmt.mib-2.system.SysLocation
iso.org.dod.internet.mgmt.mib-2.system.SysContact
iso.org.dod.internet.mgmt.mib-2.system.SysName

Pastinya dengan keterangan tersebut sudah sedikit paham bukan tentang pemanfaatan informasi SNMP yang telah ada pada perangkat jaringan ? Mari kita lanjutkan ke tahap selanjutnya untuk melakukan proses utak-utik nya. Jadi seperti yang saya janjikan sebelumnya, kita akan menambahkan informasi tambahan pada kotak tampilan setiap perangkat jaringan yang kita pantau dan menambahkan beberapa informasi yang sangat bermanfaat pastinya.

Para administrator jaringan pastinya akan sangat bahagia apabila beberapa informasi yang dulunya tak mungkin untuk dibagi, sekarang memungkinkan untuk dibagi tetapi pastinya tetap dalam koridor pengawasan sang administrator jaringan. Pernah terpikir untuk mengelola perangkat jaringan berbasis web yang mengharuskan kita untuk memeriksanya satu persatu disetiap harinya ? Hmmm … tidak lagi deh. Kalaupun jumlah perangkat masih dibawah 20 – 30 buah setidaknya ada waktu lah untuk melakukan pemeriksaan setiap harinya, lhaaa kalau sudah diatas ratusan atau di angka 50 – 100 unit capek juga kan.

Membuat Probe

Nah pada fitur The Dude ini memungkinkan kita untuk membuat sebuah pengingat (Alarm) apabila apabila sebuah informasi pada OID SNMP mengalami sebuah perubahan, misalkan pada sebuah perangkat jaringan wireless radio mengalami tidak terkoneksi, ataupun salah satu service file sharing atau database MySQL pada server mengalami mati secara tiba-tiba. Nah pada The Dude ini memungkinkan kita untuk memberikan informasi tersebut terlebih dahulu meskipun apabila dipantau dengan menggunakan ping perangkat jaringan atau server tersebut menyala.

Secara default The Dude telah mengesetkan beberapa service yang memungkinkan kita untuk memantau perangkat jaringan, seperti diantaranya ping,http,ftp,smtp,pop3,ssh ,disk,telnet dan sebagainya. Nah apabila salah satu service tersebut tidak ada bagaimana ?Hmmm tidak ada jalan lain selain kita membuatnya sendiri. Nah karena pada topik kita ini adalah pengesetan menggunakan informasi SNMP, tak ada salahnya bukan kalau kita membuatnya.

Untuk menambahkan probe klik pada tombol + (Plus) maka akan keluar sebuah jendela baru untuk menambahkan. Lihat pada gambar dibawah ini, terlihat untuk melakukan probe pada perangkat Canopy BH (BackHaul) Slave dimana probe yang dibuat ini mengharuskan informasi OID SNMP pada perangkat tersebut harus REGISTERED. Apabila informasi tersebut bukan yang dimaksud maka akan dianggap mati.

Pastikan anda memilih OID SNMP yang tepat untuk membuat sebuah probe, untuk contoh yang saya buat diatas adalah membuat probe apabila sebuah link mengalami gangguan. Sehingga nantinya hanya akan ada tiga buah kesimpulan saja, terjadi mati lampu (listrik), perangkat jaringan mengalami kerusakan dan terjadinya kerusakan selain yang tadi disebutkan yang mungkin saja bisa berupa gangguan frekuensi.

Pembuatan probe dapat dilakukan dengan mudah dengan cara mengklik kanan pada mouse pada informasi yang telah ditampilkan oleh snmpwalk, lalu pilih Create Probe

Menampilkan OID SNMP pada perangkat

Sebelum anda menambahkan informasi OID SNMP pada perangkat bagaimana kalau anda melakukan terlebih dahulu snmpwalk dan mungkin saja ada informasi yang terlewat tetapi ingin anda tampilkan. Apabila anda belum mempunyai ide informasi OID SNMP apa yang memungkinkan untuk ditampilkan ?anda bisa memilih CPU, DISK, MEMORY, atau berdasarkan informasi dari anda melakukan snmpwalk. Dibawah ini merupakan salah satu contoh nya. Yang perlu diperhatikan disini adalah bagaimana penulisan OID SNMP nya, yaitu dituliskan dengan angka !

Apabila anda merasa kesulitan untuk mendapatkan informasi OID SNMP dalam bentuk angka, klik kanan pada informasi yang sudah ditampilkan oleh snmpwalk lalu pilih Copy Oid

Apabila anda salah mengisikan informasi OID SNMP, maka informasi tersebut tidak akan muncul. Berikut ini gambar hasil akhir utak-utik saya

MRTG di The Dude

Multi Router Traphic Grapher (MRTG) ? bukan…. bukan …. kok. Meskipun hasil akhirnya adalah sama-sama menghasilkan sebuah grafik atas perbandingan data bit keluar masuk. Meskipun perbedaan nya jelas, bahwa MRTG hanya dapat dilihat dengan menggunakan media web server. Meskipun tidak ada perbedaan yang begitu mencolok antara hasil grafik yang dihasilkan oleh The Dude dan MRTG (Maaf kalau belum pernah melakukan proses uji nya, hanya berdasarkan atas dokumentasi yang dipahami. CMIIW) bahkan apabila dibahas persamaan nya kita akan mendapatkannya banyak hal, seperti keharusan pengesetan SNMP Community.

Dikarenakan The Dude adalah software pemantau jaringan yang dibuat oleh Mikrotik, maka bahasan selanjutnya akan terfokus bagaimana menampilkan grafik bit data keluar-masuk pada router berbasiskan mikrotik (routerboard). Untuk menampilkan sebuah grafik bit data keluar-masuk pastikan anda sebuah menggambar link pada topologi jaringan pantau anda.

Pastikan anda menentukan target device ethernet yang ingin anda pantau menggunakan The Dude, bisa saja koneksi keluar atau malahan koneksi lokal (LAN). Meskipun pada gambar yang saya ambil koneksinya sedang mati, terlihat bahwa jenis nya mengharuskan snmp. Untuk pengguna router mikrotik maka secara otomatis sebuah device ethernet akan muncul pada menu Interface. Terakhirnya untuk menambahkan agar setiap saat bisa mengetahui pergerakan grafik bit data keluar-masuk berikan tanda centang pada tab menu History untuk pengesetan Graph Bit Rate

semoga bisa membantu bagi temen-temen yang lagi ngeset The Dude untuk memantau perangkat jaringannya

2 ISP 1 ROUTER WITH LOAD BALANCING (MIKROTIK)

/ ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local comment=”” \
disabled=no
add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 \
comment=”” disabled=no
add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 \
comment=”” disabled=no
/ ip firewall mangle
add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 \
action=mark-connection new-connection-mark=odd passthrough=yes comment=”” \
disabled=no
add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing \
new-routing-mark=odd passthrough=no comment=”” disabled=no
add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \
action=mark-connection new-connection-mark=even passthrough=yes comment=”” \
disabled=no
add chain=prerouting in-interface=Local connection-mark=even action=mark-routing \
new-routing-mark=even passthrough=no comment=”” disabled=no
/ ip firewall nat
add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
to-ports=0-65535 comment=”” disabled=no
add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
to-ports=0-65535 comment=”” disabled=no
/ ip route
add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment=”” \
disabled=no

Mangle

/ ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local comment=”” \
disabled=no
add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 \
comment=”” disabled=no
add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 \
comment=”” disabled=no

router punya 2 upstream (WAN) interfaces dengan ip address 10.111.0.2/24 and 10.112.0.2/24. dan interface LAN dengan nama

interface “Local” dan ip address 192.168.0.1/24.

/ ip firewall mangle

add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 \
action=mark-connection new-connection-mark=odd passthrough=yes comment=”” \
disabled=no

add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing \
new-routing-mark=odd passthrough=no comment=”” disabled=no

add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \
action=mark-connection new-connection-mark=even passthrough=yes comment=”” \
disabled=no
add chain=prerouting in-interface=Local connection-mark=even action=mark-routing \
new-routing-mark=even passthrough=no comment=”” disabled=no

NAT

/ ip firewall nat
add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
to-ports=0-65535 comment=”” disabled=no
add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
to-ports=0-65535 comment=”” disabled=no

Routing

/ ip route
add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
comment=”” disabled=no
add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment=”” \
disabled=no comment=”gateway for the router itself”

NB : NTH yaitu :

Angka Pertama = Every (N)
Angka Kedua = Counter (T)
Angka Ketiga = Packet (H)

1,1,0 berarti

1 ( 2 paket, 0-1)
1 ( 1 paket)
0 ( paket yg pertama)

Troubleshooting Komputer

Troubleshooting, adalah sebuah istilah dalam bahasa Inggris, yang merujuk kepada sebuah bentuk penyelesaian sebuah masalah. Troubleshooting merupakan pencarian sumber masalah secara sistematis sehingga masalah tersebut dapat diselesaikan. Troubleshooting, kadang-kadang merupakan proses penghilangan masalah, dan juga proses penghilangan penyebab potensial dari sebuah masalah. Troubleshooting, pada umumnya digunakan dalam berbagai bidang, seperti halnya dalam bidang komputer, administrasi sistem, dan juga bidang elektronika dan kelistrika

1. Troubleshooting dalam merakit, upgrade dan overcloacking komputer
TROUBLESHOOTING MERAKIT KOMPUTER
Membongkar PC, tidak lain adalah menguraikan PC yang ada menjadi tinggal komponen-komponennya saja. Semua komponen yang ada terutama yang memang ditambahkan harus kita copot. Hal ini biasa dilakukan untuk proses troubleshooting bila PC Anda mengalami suatu permasalahan (misalnya tidak menyala).
Secara umum yang termasuk dalam komponen PC antara lain : Motherboard, Card Monitor (VGA Card), Sound Card, Prosesor, FDD, HDD, CD-ROM Drive, Port tambahan, dan kabel-kabel penghubung.
1. Komputer bisa diupgrage atau tidak ?
Ada beberapa pertimbangan yang harus dilakukan sebelum proses upgrade dilakukan, diantaranya :
  1. Motherboard

Pengecekan Motherboard sangatlah penting karena komponen upgrade tersebut akan dipasangkan padamotherboard, dengan mengetahui kemampuan dari motherboard maka anda dapat leluasa menentukan komponen apa yang dapat diupgrade dan komponen penggantinya tentu yang sesuai dengan motherboard.

Berikut ini langkah pengecekan :

• Lakukan cek apakah motherboard “support” atau tidak terhadap komponen yang akan anda tambahkan, meliputi :

• Upgrade RAM, lihat slot yang kosong.

• Upgrade VGA Card, lihat slot yang digunakan oleh VGA yang dulu.

o Baca manual Motherboard, kenali jenis dari slot (PCI, AGP, ISA) yang ada, khusus untuk AGP kenali apakah AGP anda itu AGP 1x, AGP 2x,atau AGP 4x.

o Untuk Upgrade processor, ketahui apakah motherboard anda mendukung terhadap prosesor yang anda inginkan, jika tidak maka ganti motherboard anda namun perlu diperhatikan agar motherboard anda yang baru ini mendukung kecepatan bus dari prosesor yang anda inginkan (kalau bisa mendukung kecepatan bus terbaru). Jika ternyata motherboard anda sudah mendukung prosesor yang anda inginkan, maka prosesor yang baru itu hendaknya mendukung kecepatan bus yang sama dengan motherboard

2. Case

Pengecekan Case ini perlu untuk melihat ruang kosong jika kita ingin menambah drive dan jika kita mengganti motherboard, periksa apakah case kita cocok dengan motherboard baru yaitu bagian sumber power, AT atau ATX, jika ternyata motherboard mendukung semuanya tidak apa, namun jika motherboard terbaru umumnya mendukung ATX, jika case kita AT maka terpaksa harus diganti.

3. RAM

Upgrade memory sangat baik, karena akan meningkatkan kecepatan akses dan kerja komputer dan hal itu akan sangat tampak apabila kita menjalankan beberapa aplikasi dalam satu waktu, mis: kita menjalankan windows, kita juga menjalankan aplikasi lain seperti MsOffice, AutoCad, Adobe dan banyak lagi keuntungannya setidaknya anda aman untuk aplikasi software sekaligus.

Langkah yang dapat diambil agar mendapat hasil yang maksimal :

  • Kenali memory anda, apa slot jenis yang digunakan oleh memory anda SIMM atau DIMM? Jika menggunakan slot SIMM (72 pin) berarti anda harus menambah tipe yang sama, sebanyak min satu bank SIMM untuk mengupgradenya, untuk tipe SIMM umumnya digunakan EDORAM, satu bank SIMM = 2 keping SIMM. Jika menggunakan slot DIMM (168pin) berati anda harus menambah min satu bank DIMM untuk mengupgradenya, satu bank DIMM = 1 keping DIMM
  • Clock RAM, RAM yang ditambahkan hendaknya memiliki clock yang sama dengan RAM yang sudah ada. Jika ternyata clock RAM yang baru itu lebih cepat/lambat, maka keseluruhan RAM akan bekerja dengan kecepatan clock yang paling rendah diantara keping-keping RAM tersebut. Clock RAM hendaknya juga sama dengan clock dari Motherboard agar didapatkan kerja yang maksimal.

4. Procesor

Upgrade processor dapat dilakukan melalui 2 hal :

  • Membeli kit Upgrade processor, yang dimaksud dengan kit ini, merupakan suatu bentuk paket upgrade dengan menggunakan teknologi overdrive. Tiga vendor – Evergreen Technologies, Kingston Technology dan Power Leap – menawarkan Upgrade CPU dengan aneka prosesor termasuk AMD K6-2 dan K6-III dan Intel Celeron. Namun upgrade processor dengan cara ini kurang disenangi karena ada saja masalah yang timbul sepertikesulitan saat ‘shutdown’, tidak cocok dengan BIOS yang ada sehingga harus mencari atau melakukan update BIOS. Contoh : AcceleraPCI dari Evergreen untuk Celeron.
  • Processor baru, merupakan cara upgrade yang paling sering dilakukan namun ada hal-hal yang perlu diperhatikan diantaranya :
    • Motherboard anda harus mendukung kecepatan bus dari prosesor
    • Clock speed dari prosesor makin cepat makin baik.
    • Dukungan cache memory dari processor(L1 cache dan atau L2 cache)

5. Harddisk

Prosesor yang bagus serta RAM yang cukup memadai memang akan mendorong kecepatan kerja dari sebuah PC, namun agar bisa bekerja dengan baik tentu dibutuhkan media penyimpan dengan kapasitas yang cukup besar. Kebutuhan ruang disk yang besar ini disebabkan perkembangan software yang kian lama kian membutuhkan ruang yang banyak. Munculnya pemikiran untuk mengganti harddisk yang dimiliki dengan harddisk lain yang memiliki kapasitas yang lebih besar merupakan salah satu cara untuk mempersiapkan media penyimpan yang lebih besar. Sekarang harddisk yang tersedia di pasaran umumnya berukuran 4,3 GB (minimal) dalam mengupgrade harddisk tentunya kita menginginkan harddisk dengan kapasitas besar yang kita perkirakan aman untuk 2-3 tahun kedepan, bukan hanya itu saja kita juga ingin harddisk dengan teknologi terbaru untuk harddisk IDE/EIDE dengan teknologi Ultra DMA/66 atau Ultra ATA/66 yang secara teoritis dapat mentransfer data 66 megabits per detik, namun hal ini harus dilihat apakah motherboardnya mendukung atau tidak. Untuk anda yang memiliki komputer lama, anda pertama-tama harus mencek BIOS anda apakah dapat menangani harddisk dengan kapasitas besar khususnya harddisk yang berukuran diatas 8.4 GB, jika sekiranya tidak mendukung anda dapat terlebih dahulu melakukan Update BIOS dengan men-download dari vendor mother board anda atau dari vendor BIOS itu sendiri. Jika untuk individu baiknya digunakan harddisk EIDE saja, namun jika untuk Server gunakan jenis SCSI.

6. ZIP DRIVE + Media Penyimpan Lainnya

Jika data yang disimpan itu sering berpindah-pindah dan kapasitasnya besar anda dapat menggunakan ZIP Drive yang memiliki catridge penyimpan yang cukup besar sekitar 100MB atau dengan menggunakan drive Jazz SCSI dengan kapasitas 2 GB dan drive ORB dengan kapasitas 2,2 BG. Suatu tawaran menarik dapat pula anda ambil dengan menggunakan CD-Recordable yang memiliki kapasitas tiap Cdnya sekitar 650MB, hal yang demikian ini sedang populer dikalangan kita khususnya untuk menyimpan file mp3 karena sering dipertukarkan dan sebagai pengganti CD music. Namun agar anda dapat melakukannya anda harus memiliki drive CD-RW nya.

7. Display

Upgrade display mungkin adalah bentuk upgrade yang sering dilakukan orang jika kita hanya melihat komponen tertentu dari display. Namun upgrade display ini terkadang dianggap bukanlah suatu hal yang penting terutama bagi orang yang tidak begitu menyenangi game komputer. Upgrade display itu sendiri meliputi upgrade monitor saja, kartu grafis saja atau kedua-duanya.

8. Monitor

Monitor yang kita pilih haruslah monitor yang memiliki dukungan resolusi yang tinggi sehingga tampilan yang dihasilkan akan lebih tajam dan lebih hidup dan memilki dukungan terhadap tampilan warna yang tinggi, bagi para pemilik monitor yang lama dapat menggantinya (jikalau mau) dengan monitor flatscreen yang sudah banyak dipasaran dan tentunya dengan layar yang lebih besar setidaknya 15”. Namun bagi anda yang penggemar game layar yang lebih besar akan lebih memberikan kepuasan semua itu kembali ke “kantong” masing-masing.

9. VGA Card

Namun peningkatan display tidak hanya dari kualitas monitor saja, upgrade kartu grafis juga akan memberikan pengaruh yang tidak sedikit. Jika anda hanya menggunakan komputer anda sebatas dokumen pengolahan kata, operasi pada spreadsheet atau untuk “surving” kartu grafis anda sekarang sudah cukup. Namun jika anda banyak bekerja dengan aplikasi 3D berat atau anda pecandu game maka upgrade kartu grafis dapat menjadi sebuah pilihan yang cukup menggiurkan, terlebih lagi jika motherboard anda memiliki slot AGP, pilihan untuk Upgrade VGA card cukup banyak. Namun dari sekian banyak opsi yang tersedia untuk upgrade VGA yang perlu anda perhatikan dari sebuah kartu grafis adalah kecepatan RAMDACnya – sebuah chip yang mengkonversikan grafik PC kedalam sinyal analog merah, hijau, biru. Yang digunakan oleh monitor. Semakin cepat RAMDAC dari dari sebuah kartu grafis semakin halus gambar yang dihasilkan (semakin bagus kualitasnya). Vga yang menggunakan Chipset RivaTNT2, Voodoo 3, Matrox G400, Savage4 dapat menjadi pilihan terutama bagi anda yang GAME MANIA, serta usahakan memiliki memory VGA min 16 MB

10. Port

Anda mengalami kebingungan ketika ingin menambah komponen komputer anda karena port yang tersedia terlalu sedikit, seperti kamera desktop, scanner, kamera digital yang pada umumnya diproduksi sekarang ini dengan port USB (Universal Serial Bus), periksalah komputer anda apakah memiliki port USB ini. Port USB ini bentuknya seperti colokan persegi kecil yang berada pada panel belakang system. Port USB ini memiliki kecepatan transfer data yang lebih cepat dari port serial biasa sekitar 12 Mbps, USB juga merupakan Plug-and-Play sejati dan hot-swapping (dapat dikoneksi atau diskoneksi dengan peripheral tanpa harus mematikan PC. Jika anda measa membutuhkan port USB ini, hal pertama yang harus anda lakukan cek motherboard anda (ada USB atau tidak) apakah mendukung penambahan port USB (jika tidak ada), bila mendukung anda dapat menghubungi pembuat PC tersebut, untuk mendapatkan adapter yang diperlukan, untuk menghubungkan konektor motherboard ke panel belakang, bila tidak ada anda dapat membeli kartu add-in seperti Entrega 2-port USB upgrade. OS yang butuhkan untuk mendukung USB minimal win 95 OSR-2

11. CD-RW vs DVD

DVD-ROM merupakan salah satu alternatif bagi anda CD-ROM anda sudah usang dan ingin menggantinya, itupun jika anda menginginkannya. DVD-ROM akan memberikan tampilan movie yang lebih baik, sebuah kit DVD-ROM terdiri dari DVD-ROM drive dan decoder card, decoder card dibutuhkan untuk memutar film DVD, karena jia menggunakan decoder MPEG-2 secara software akan memberikan hasil yang kurang bagus, selain itu decoder secara software ini membutuhkan PC high-end dan pemasangan DVD ini juga agak rumit. Sebuah DVD-ROM $200-350$.

CD-RW merupakan alternatif pilihan yang cukup baik bagi anda yang ingin mengganti CD-ROM. CD-RW dapat memungkinkan anda untuk menyinpan data pada disk dan membacanya, selain itupula CD-RW memungkin anda untuk membuat CD musik anda sendiri. Memiliki CD-RW berarti juga anda memiliki sebuah upgrade media penyimpan karena anda dapat menyimpan data anda pada CD dengan kapasitas sekitar 600 MB. Selain itu anda dapat berbisnis dengan memiliki CD-RW seperti yang banyak ditekuni para pemilik CD-RW (namun sifatnya ilegal). Sebuah CD-RW $350-600.

2. Perlukah dilakukan Overcloacking ?

Overclock atau Overclocking adalah mengubah/mengatur kecepatan dari processor/CPU diatas kecepatan normal yang tertera pada processor tersebut.

Teknik atau cara yang dapat dilakukan untuk overclocking yaitu :

1. Meningkatkan Multiplier.

2. Meningkatkan Bus clock.

3. Meningkatkan Bus clock dan Multiplier

Ketiga cara diatas dapat dilakukan secara fisik (hardware) maupun secara software.

• Cara Hardware

Melakukan perubahan pada setting jumper/switch yaitu pada jumper yang mengatur bus clock dan mengatur multiplier.

• Cara software

Melakukan perubahan pada bus clock atau Multiplier dengan mengaturnya pada BIOS melalui softmenu. Umumnya cara overclock semacam ini ada pada motherboard yang baru yang menggunakan jumperless dan BIOS yang memiliki softmenu tersebut

Faktor-faktor yang perlu diperhatikan dalam overclock, diantaranya:
1 Bus

Secara umum bus adalah penghubung secara fisik antar unit-unit dalam komputer dan antara komputer dengan dunia luar. Pendapat lain dikatakan bus adalah kumpulan garis atau kawat yang membawa sinyal pada komputer. Bus clock adalah frekuensi kerja dari bus yang ada pada motherboard. Bus clock itu sendiri berbeda-beda pada motherboard, yaitu 25 MHz, 30MHz, 33 MHz, 40 MHz, 50 MHz ini merupakan bus clock dari motherboard 486, sedangkan untuk motherboard Pentium keatas sudah menggunakan bus clock 60 MHz, 66 MHz, 75 Mhz, 83 MHz dan 100 MHz bahkan motherboard sekarang ada yang mampu mendukung sampai 150 MHz. Untuk bus clock >= 100 digunakan untuk prosesor Pentium II, Pentium III atau yangh setara dengannya. Pengguanaan bus clock harus =< dari clock memori agar tidak terjadi crash. Bus clock sering pula dikenal sebagai Bus frekuensi.

2. CPU clock & Multiplier
CPU clock atau CPU speed adalah frekuensi kerja dari prosesor. Misalkan Pentium II 350 maka Cpu clocknya 350MHz, artinya tiap detik prosesor akan melakukan 350 juta cycle ‘putaran’ dimana tiap satu cycle prosesor dapat melakukan beberapa operasi sedrhana atau beberapa cycle untuk sebuah operasi yang komplex. Multiplier ‘pengali’ adalah suatu faktor yang menjadi faktor pembanding antara Cpu clock dan bus clock dengan rumus:
CPU clock = Bus clock x multiplier
Misal pentium 350 berarti bila menggunakan bus clock 100 mengunakan multiplier 3,5. Pengaturan multiplier dan bus clock pada pentium biasa dan sampai AMD K6-3 masih menggunakan jumper atau switch, sedangkan untuk motherboard yang ‘jumperless’ menggunakan set BIOS digunakan pada pentium II, pentium III, pentium Xeon.

3. Jumper & Switch

Jumper adalah alat yang berfungsi sebagai saklar dan switch, wujud fisiknya biasanya berupa pin-pin yang menonjol pada motherboard. Sebagai pelengkap jumper disertakan konektor yang berguna untuk menghubungkan pin-pin pada jumper. Umumnya konektor menghubungkan 2 pin. Jumper 2 pin bila pinnya dihubungkan oleh konektor maka jumper berfungsi sebagai saklar sedangkan untuk jumper 3 pin jumper berfungsi sebagai switch, karena kombinasinya bisa 1-2 atau 2-3. Pada motherboard (socket 7) banyak sekali terdapat jumper untuk mengetahui fungsinya digunakan manual motherboard. Switch adalah kumpulan jumper-jumper yang bertugas bersama, pengaturan switch akan berpengaruh pada seluruh pengaturan jumper tersebut. Contoh penggunaannya pada pengaturan Bus clock, multiplier dan CPU voltage pada DFI motherboard super 7.

Mengatasi masalah panas
Overclocking akan mengakibatkan timbulnya panas yang cukup berlebihan, jika kita tidak menggunakan pendingin, untuk dapat overclocking dengan aman maka kita harus memiliki sistem pendingin yang baik pula. Sistem pendingin terbagi 2 :
• Software
Banyak sofware yang beredar yang dapat digunakan sebagai software pendingin seperti waterfall dan rain.
• Hardware
dengan memasang heatsink dan kipas pada processor atau memakai hardware khusus, yang memang bekerja sebagai pendingin seperti kyro 1.

Dampak Overclock
Dampak negatif overclock:
1. Panas berlebihan pada prosesor karena dipaksa bekerja pada clock yang lebih tinggi, dapat dikurangi dengan penggunaan sistem pendingin yang sudah ada.
2. Kesalahan operasi (pehitungan) prosesor karena akibat panas berlebihan.
Dampak positif overclock:
1. Komputer menjadi lebih cepat seolah-olah bekerja dengan prosesor yang lebih tinggi.
2. Cara termurah meningkatkan kecepatan kerja dari CPU.
3. Dapat membuat prosesor yang tidak ada pada pasaran.

Kesalahan atau ketidakberhasilan dalam merakit komputer umumnya disebabkan antara lain :

  1. Pemasangan Memori yang tidak benar, Motherboard yang baik akan memberi sinyal suara peringatan bahwa pemasangan memori tidak benar. Cek dan pasang dengan benar.
  2. Pemasangan Card AGP atau VGA yang kurang kencang atau pas, Motherboard yang baik akan memberikan sinyal suara peringatan. Cck dan pasang dengan benar.
  3. Pemasangan Kabel data untuk HardDisk yang tidak pas atau terbalik. Atau pengaturan posisi Master atau Slavepada HardDisk yang tidak tepat. Betulkan serta check pada jumper HardDisk untuk posisi Master/Slave dan cek dengan autodetect HardDisk pada BIOS.
  4. Pemasangan Kabel Data Disk Drive yang tidak pas atau terbalik.
  5. Pemasangan panel connector yang tidak tepat sehingga lampu Indicator untuk HardDisk dan Power On tidak aktif.

Pada tabel berikut ini akan diuraikan beberapa gejala yang mungkin timbul pada PC anda setelah anda melakukan perakitan, upgrade ataupun overclock.

MENGENAL PROTOKOL INTERNET

MENGENAL PROTOKOL INTERNET

(TCP/IP)

Agar
jaringan intrenet ini berlaku semestinya harus ada aturan standard yang
mengaturnya karena itu diperlukan suatu protokol internet.

Sejarah
TCP/IP

Internet
Protocol
dikembangkan pertama kali oleh Defense Advanced Research
Projects Agency
( DARPA) pada tahun 1970 sebagai awal dari usaha
untuk mengembangkan protokol  yang dapat melakukan interkoneksi
berbagai jaringan komputer yang terpisah, yang masing-masing jaringan
tersebut menggunakan teknologi yang berbeda. Protokol utama yang dihasilkan
proyek ini adalah Internet Protocol (IP). Riset yang sama dikembangkan
pula yaitu beberapa protokol level tinggi yang didesain dapat bekerja
dengan IP. Yang paling penting dari proyek tersebut adalah Transmission
Control Protocol
(TCP), dan semua grup protocol diganti dengan TCP/IP
suite
. Pertamakali TCP/IP diterapkan di ARPANET, dan mulai berkembang
setelah Universitas California di Berkeley mulai menggunakan TCP/IP
dengan sistem operasi  UNIX.  Selain Defense Advanced Research
Projects Agency
(DARPA) ini yang mengembangkan Internet Protocol,
yang juga mengembangkan TCP/IP adalah Department of defense (DOD).

Istilah-istilah
didalam Internet Protocol

Ada beberapa istilah yang sering ditemukan didalam pembicaraan mengenai
TCP/IP, yaitu diantaranya :

Host
atau end-system, Seorang pelanggan pada layanan jaringan komunikasi.
Host
biasanya berupa individual workstation atau personal
computers
(PC) dimana tugas dari Host ini biasanya adalah
menjalankan applikasi dan program software server yang berfungsi sebagai
user dan pelaksana pelayanan jaringan komunikasi.

Internet,
yaitu merupakan suatu kumpulan dari jaringan (network of networks)
yang menyeluruh dan menggunakan protokol TCP/IP untuk berhubungan
seperti virtual networks.

Node,
adalah istilah yang diterapkan untuk router dan host.protocol,
yaitu merupakan sebuah prosedur standar atau aturan untuk pendefinisian
dan pengaturan transmisi data antara komputer-komputer.

Router,
adalah suatu devais yang digunakan sebagai penghubung antara dua
network
atau lebih.  Router berbeda dengan host
karena router bisanya bukan berupa tujuan atau data traffic.
Routing
dari datagram IP biasanya telah dilakukan dengan software.
Jadi fungsi routing dapat dilakukan oleh host yang mempunyai
dua networks connection atau lebih.

Overview
TCP/IP

Sebagaimana yang telah dikemukakan di atas, TCP/IP juga dikembangkan
oleh Department of Defense (DOD). DOD telah melakukan proyek
penelitian untuk menghubungkan beberapa jaringan yang  didesain
oleh berbagai vendor untuk menjadi sebuah networks of networks
(Internet). Pada awalnya hal ini berhasil karena hanya menyediakan pelayanan
dasar seperti file transfer, electronic mail, remote logon.  Beberapa
komputer dalam sebuah departemen dapat menggunakan TCP/IP (bersamaan
dengan protokol lain) dalam suatu  LAN tunggal. Komponen IP menyediakan
routing
dari departmen ke network enterprise, kemudian
ke jaringan regional  dan akhirnya ke global internet. Hal ini
dapat menjadikan jaringan komunikasi dapat  rusak, sehingga untuk
mengatasinya maka kemudian DOD mendesain TCP/IP yang dapat memperbaiki
dengan otomatis apabila ada node atau saluran telepon yang gagal.
Hasil rancangan ini memungkinkan untuk membangun jaringan yang sangat
besar  dengan pengaturan pusat yang sedikit. Karena adanya perbaikan
otomatis maka masalah dalam jaringan  tidak  diperiksa dan
tak diperbaiki untuk waktu yang lama.

Seperti halnya
protokol  komunikasi yang lain, maka  TCP/IP pun mempunyai
beberapa layer, layer-layer itu adalah :

  • IP (internet
    protocol
    ) yang berperan dalam pentransmisian paket data dari
    node
    ke node. IP mendahului setiap paket  data berdasarkan
    4 byte (untuk versi IPv4) alamat tujuan (nomor IP). Internet authorities
    menciptakan range angka untuk organisasi yang berbeda. Organisasi menciptakan
    grup dengan nomornya  untuk departemen. IP bekerja pada  mesin
    gateaway
    yang memindahkan data dari departemen ke organisasi kemudian
    ke region dan kemudian ke seluruh dunia.
  • TCP (transmission
    transfer protocol
    ) berperan didalam memperbaiki pengiriman data
    yang benar dari suatu klien ke server. Data dapat hilang di tengah-tengah
    jaringan. TCP dapat mendeteksi error atau data yang hilang dan kemudian
    melakukan transmisi ulang sampai data diterima dengan benar dan lengkap.
  • Sockets yaitu
    merupakan nama yang diberikan kepada subrutin paket yang menyediakan
    akses ke TCP/IP pada kebanyakan sistem.

Bebrapa
hal penting didalam TCP/IP

1. Jaringan
Peminta Terendah  (Network of Lowest Bidders)

IP
dikembangkan untuk membuat sebuah network of networks (Internet).
Individual machine
dihubungkan ke LAN (ethernet atau Token ring).
TCP/IP membagi LAN dengan user yang lain (Novell file server, windows
dll). Satu devais menyediakan TCP/IP menghubungkan antara LAN dengan
dunia luar.
Untuk meyakinkan bahwa semua tipe sistem dari berbagai vendor
dapat berkomunikasi, maka penggunaan TCP/IP distandarkan pada
LAN. Dengan bertambahnya kecepatan mikroprossesor, fiber optics, dan
saluran telepon digital maka telah menciptakan beberapa pilihan teknologi
baru diantaranya yaitu ISDN, frame relay, FDDI, Asynchronous
Transfer Mode
(ATM).
Rancangan asli dari TCP/IP adalah sebagai sebuah  network of
networks
yang cocok dengan penggunaan teknologi sekarang ini.
Data TCP/IP dapat dikirimkan melalui sebuah LAN, atau dapat dibawa dengan
sebuah jaringan internal corporate SNA, atau data dapat terhubung
pada TV kabel . Lebih jauh lagi, mesin-mesin yang  berhubungan
pada salah satu jaringan tersebut   dapat berkomunikasi dengan
jaringan yang lain melalui gateways yang disediakan vendor
jaringan .

2. Masalah
Pengalamatan

Dalam
sebuah jaringan SNA , setiap mesin mempunyai Logical Units dengan
alamat jaringan  masing-masing. DECNET, Appletalk, dan Novell IPX
mempunyai rancangan untuk membuat nomor untuk setiap jaringan lokal
dan untuk setiap workstation yang terhubung ke jaringan.

Pada
bagian utama  pengalamatan lokal network, TCP/IP membuat nomor
unik untuk setiap workstation di seluruh dunia. Nomor IP adalah
nilai 4 byte (IPv4) dengan konvensi merubah setiap byte ke dalam nomor
desimal (0 sampai 255 untuk IP yang digunakan sekarang) dan memisahkan
setiap bytes  dengan periode. Sebagai contoh misalnya 130.132.59.234.

Sebuah
organisasi dimulai dengan mengirimkan electronic mail ke Hostmaster@INTERNIC.NET
meminta untuk pembuatan nomor jaringan. Hal ini dimungkinkan bagi hampir
setiap orang untuk  memperoleh nomor untuk jaringan “small
class C” dengan 3 bytes pertama meyatakan jaringan dan byte terakhir
menyatakan individual komputer. Organisasi yang lebih besar dapat memperoleh
jaringan “Class B” dengan 2 bytes pertama menyatakan jaringan
dan 2 bytes terakhir menyatakan menyatakan masing-masing workstation
sampai mencapai 64.000 individual workstation. Contoh  Jaringan
Class
B Yale adalah 130.132, jadi semua komputer dengan IP address
130.132.*.* adalah dihubungkan melalui Yale.

Kemudian
organisasi berhubungan dengan intenet melalui satu dari beberapa jaringan regional  atau
jaringan khusus.  vendor jaringan diberi nomor pelanggan
networks
dan ditambahkan ke dalam  konfigurasi routing
dalam masing-masing mesin.

Tidak
ada rumus matematika yang mengubah nomor 192.35.91 atau 130.132 menjadi
“Yale University” atau “New Haven”. Mesin-mesin
yang mengatur jaringan regional yang besar  atau  routers
Internet pusat dapat menentukan lokasi jaringan-jaringan tersebut dengan
mencari setiap nomor jaringan tersebut dalam tabel. Diperkirakan ada
ribuan jaringan class B dan jutaan jaringan class C. Pelanggan yang
terhubung dengan Internet, bahkan perusahaan besar seperti IBM tidak
perlu untuk memelihara informasi pada jaringan-jatingan yang lain. Mereka
mengirim semua eksternal data ke regional carrier yang mereka
langgan, dan regional carrier mengamati dan memelihara tabel
dan melakukan  routing
yang tepat.

3. Subnets

Meskipun
pelanggan individual tidak membutuhkan nomor tabel jaringan atau menyediakan
eksplisit routing, tapi untuk kebanyakan jaringan class B dapat
diatur secara internal sehingga lebih kecil dan versi organisasi jaringan
yang lebih sederhana. Biasanya membagi dua byte  internal assignment
menjadi satu byte nomor departmen dan satu byte Workstation ID.

Enterprise
network
dibangun dengan menggunakan TCP/IP router box secara
komersial. setiap router mempunyai tabel dengan 255 masukan
untuk  mengubah satu byte nomor departmen menjadi pilihan tujuan
ethernet  yang terhubung ke salah satu router. Misalnya,
pesan ke 130.132.59.234 melalui jaringan regional National dan New
England  berdasarkan bagian nomor 130.132. Tiba di Yale, 59 department
ID memilih ethernet connector .  234 memilih workstation
tertentu  pada LAN. Jaringan Yale harus diupdate sebagai ethernet
baru dan departemen ditambahkan, tapi tidak dipengaruhi oleh perubahan
dari luar atau perpindahan mesin dalam departemen.

4. Jalur-jalur
tak tentu

Setiap
kali sebuah pesan tiba pada sebuah IP router,  maka router
akan  membuat keputusan  ke mana berikutnya pesan tersebut
akan dikirimkan. Ada konsep satu waktu tertentu  dengan preselected
path
untuk semua traffic. Misalkan sebuah perusahaan dengan
fasilitas di New York, Los Angles, Chicago dan Atlanta.  Dapat
dibuat jaringan dari empat jalur telepon  membentuk sebuah loop
(NY ke Chicago ke LA ke Atlanta ke NY). Sebuah pesan tiba di router
NY dapat pergi ke LA melalui Chicago atau melalui Atlanta. jawaban
dapat kembali ke jalan lain.

Bagaimana
sebuah router dapat membuat keputusan antara router dengan
router
? tidak ada jawaban yang benar. Traffic dapat dipetakan dengan
algoritma “clockwise” (pergi ke NY ke Atlanta, LA ke chicago).
Router
dapat menentukan, mengirimkan pesan ke Atlanta kemudian selanjutnya
ke ke Chicago. Routing yang lebih baik adalah dengan mengukur
pola traffic dan mengirimkan data melalui link
yang paling tidak sibuk.

Jika
satu saluran telepon dalam satu jaringan rusak, pesan dapat tetap mencapai
tujuannya melalui jalur yang lain. Setelah kehilangan jalur dari NY
ke Chicago, data dapat dikirim dari NY ke Atlanta  ke LA
ke Chicago. Dengan begitu maka jalur akan berlanjut meskipun dengan
kerugian performance menurun.

Perbaikan seperti
ini merupakan bagian tambahan pada desain IP.

5. Masalah
yang Tidak Diperiksa (Undiagnosed Problem)

Jika
ada error terjadi, maka dilaporkan ke network authorities. Error
tersebut harus dibenarkan atau diperbaiki. IP, didesain untuk dapat
tahan dan kuat. Kehilangan node atau jalur adalah hal  biasa,
tetapi jaringan harus tetap jalan. Jadi IP secara otomatis  menkonfigurasi
ulang dirinya sendiri bila terjadi sesuatu yang salah. Jika banyak
redundancy
yang dibangun ke dalam sistem maka komuniksi tetap
berlangsung dan terjaga. TCP dirancang untuk memulihkan node
atau saluran yang gagal dimana propagasi routing table berubah
untuk semua node router. Karena proses updating memerlukan
waktu yang lama , TCP agak lambat untuk menginisiasi
pemulihan.

6. Mengenai
Nomor IP

Setiap
perusahaan besar atau perguruan tinggi yang terhubung ke internet harus
mempunyai level intermediet network. beberapa router
mungkin dikonfigurasi untuk berhubungan dengan bebarapa department LAN.
Semua traffic di luar organisasi dihubungkan dengan koneksi tunggal
ke jaringan provider regional.

Jadi, pemakai
akhir  dapat menginstall TCP/IP pada PC tanpa harus tahu jaringan
regional . Tiga bagian informasi dibutuhkan :

  • IP address
    dibuat pada PC
  • Bagian dari IP
    address (subnet mask)
    yang membedakan mesin lain dalam LAN
    yang sama (pesan dapat dikirim secara langsung ) dengan mesin-mesin
    di departemen lain atao dimanapun di seluruh dunia ( yang dikirimkan
    ke router mesin)
  • IP address
    dari router mesin yang menghubungkan LAN tersebut dengan dunia
    luar.

7.  Susunan
TCP/IP protocol
Internet pada mulanya didesain dengan dua kriteria utama. Dua kriteria
ini mempengaruhi dan membentuk hardware dan software yang digunakan
sekarang. Kriteria  tersebut : Jaringan harus melakukan  komunikasi
antara para peneliti di belahan dunia yang berbeda, memungkinkan meraka
dapat berbagi dan berkomunikasi mengenai penelitian mereka satu sama
lain. Sayangnya, riset memerlukan berbagai komputer dari beragam platform dan arsitektur jaringan
yang berbeda untuk keperluan keilmuan. Maka untuk itu diperlukan
protocol suite
untuk dapat berhubungan dengan berbagai platforms
hardware
yang berbeda dan bahkan sistem jaringan yang berbeda. Lebih
jauh lagi, network harus merupakan jaringan komunikasi yang kuat yang
mempunyai kemampuan dapat bertahan dari serangan nuklir. Rancangan ini
memebawa ke arah desentralisasi jaringan yang terdiri dari jaringan
yang terpisah, lebih kecil, jaringan yang diisolasi yang mempunyai kemampuan
otomatis bila diperlukan.

Layer
menyediakan level abstrsaksi untuk software dan menaikkan kemampuan
menggunakan kembali dan kebebasan platform. Layer-layer tersebut
dimaksudkan untuk benar-benar terpisah dari satu sama lain dan juga
independen. Layer tersebut tidak mengandalkan informasi detail dari
layer yang lain. Arsitektur rancangan ini membuat lebih mudah untuk
melakukan pemeliharaan karena layer dapat didesain ulang atau dikembangkan
tanpa merusak integritas protokol stack.

TCP/IP
protocol suite terdiri dari 4 layers: Applikasi, Transport,
Internetwork
, dan network interface. Layer tersebut dapat
dilihat sebagai hirarki seperti di bawah ini :

Layer
Applikasi
adalah sebuah aplikasi yang mengirimkan data ke transport
layer. Misalnya FTP, email programs dan web browsers.

Layer Transport
bertanggung jawab untuk komunikasi antara aplikasi. Layer ini mengatur
aluran informasi dan mungkin menyediakan pemeriksaan error. Data dibagi
kedalam beberapa paket yang dikirim ke internet layer dengan sebuah
header.
Header mengandung alamat tujuan,
alamat sumber dan checksum. Checksum diperiksa oleh
mesin penerima  untuk melihat apakah paket tersebut ada yang hilang
pada rute.

Layer
Internetwork
bertanggung jawab untuk komunikasi antara mesin. Layer
ini meg-engcapsul paket dari transport layer ke dalam IP datagrams
dan menggunakan algoritma routing untuk menentukan kemana datagaram
harus dikirim. Masuknya datagram diproses dan diperiksa kesahannya sebelum
melewatinya pada Transport layer.

Layer
networks interface
adalah level yang paling bawah dari susunan TCP/IP.
Layer ini adalah device driver yang memungkinkan datagaram IP dikirim
ke atau dari pisikal network. Jaringan dapaat berupa sebuah kabel, Ethernet,
frame relay, Token ring, ISDN, ATM jaringan, radio, satelit atau alat
lain yang dapat mentransfer data dari sistem ke sistem. Layer network
interface
adalah abstraksi yang memudahkan komunikasi antara
multitude arsitektur network.

PENGATURAN BGP-PEER

Pertama-tama, pastikan bahwa Anda menggunakan gateway internasional Anda sebagai default route, dalam contoh ini adalah 69.1.1.1. Kemudian Anda perlu membuat sebuah static route ke mesin BGP Mikrotik Indonesia, yaitu IP 202.65.120.250.

Lalu periksalah apakah Anda bisa melakukan ping ke 202.65.120.250. Periksalah juga dengan traceroute dari router, apakah jalur pencapaian ke IP 202.65.120.250 telah melalui jalur koneksi yang diperuntukkan bagi trafik OpenIXP (NICE), dan bukan melalui jalur internasional.

Kemudian, Anda harus mendaftarkan IP Address Anda di website Mikrotik Indonesia untuk mengaktifkan layanan BGP-Peer ini. Aktivasi bisa dilakukan di halaman ini. IP Address yang bisa Anda daftarkan hanyalah IP Address yang bisa di-ping dari mesin kami, dan juga harus sudah diadvertise di OIXP. Aturan selengkapnya mengenai penggunaan layanan ini bisa dibaca di halaman ini. Setelah Anda mendaftarkan IP Address Anda, jika semua syarat sudah terpenuhi, Anda akan diinformasikan bahwa aktivasi layanan BGP-Peer Anda sudah sukses. Selanjutnya Anda bisa melihat status layanan BGP Anda di halaman ini.

BGP Router Mikrotik Indonesia akan menggunakan IP Address 202.65.120.250 dan AS Number 64888, dan Router Anda akan menjadi BGP Peer dengan menggunakan AS Number 64666.

Berikutnya adalah langkah-langkah yang harus Anda lakukan pada router Anda. Pertama-tama Anda harus membuat beberapa prefix-list untuk BGP ini. Untuk prefix yang akan Anda terima, untuk alasan keamanan dan hematnya agregasi routing, maka Anda perlu melakukan setting untuk menerima hanya prefix 8 hingga 24. Prefix 0 sampai 7, dan 25 sampai 32 akan Anda blok. Prefix ini kita berinama prefix-in. Untuk prefix-in yang accept, harap diperhatikan bahwa Anda perlu menentukan gateway untuk informasi routing ini, yaitu IP gateway OpenIXP (NICE) Anda. Dalam contoh ini adalah 202.65.113.129. Gantilah IP ini sesuai dengan gateway OpenIXP (NICE) Anda.

Sedangkan karena sifat BGP-Peer ini hanya Anda menerima informasi routing saja, di mana Anda tidak dapat melakukan advertisement, maka harus dilakukan blok untuk semua prefix yang dikirimkan, dan kita beri nama prefix-out.

Berikut ini adalah konfigurasi prefix list yang telah dibuat.

Tahap selanjutnya adalah konfigurasi BGP instance. Yang perlu di-set di sini hanyalah AS Number Anda, pada kasus ini kita menggunakan AS Number private, yaitu 64666.

Dan langkah terakhir pada konfigurasi BGP ini adalah konfigurasi peer. AS Number BGP Router Mikrotik Indonesia adalah 64888 dan IP Addressnya adalah 202.65.120.250. Karena kita sulit menentukan berapa hop jarak BGP Router Mikrotik Indonesia dengan Router Anda, maka kita melakukan konfigurasi TTL menjadi 255. Jangan lupa mengatur rule prefix-in dan prefix-out sesuai dengan prefix yang telah kita buat sebelumnya.

Setelah langkah ini, seharusnya BGP Router Mikrotik sudah dapat terkoneksi dengan Router Anda. Koneksi ini ditandai dengan status peer yang menjadi “established” dan akan dicantumkan pula jumlah informasi routing yang diterima. Anda juga bisa mengecek status peer ini dari sisi BGP Router Mikrotik Indonesia dengan melihat pada halaman ini.

Cek pula pada bagian IP Route, seharusnya sudah diterima ribuan informasi routing, dan pastikan bahwa gatewaynya sesuai dengan gateway OpenIXP (NICE) Anda, dan berada pada interface yang benar, dalam contoh ini adalah “ether2-iix”.

Jika semua sudah berjalan, pastikan bahwa penggunaan 2 buah gateway ini sudah sukses dengan cara melakukan tracerute dari router ataupun dari laptop ke beberapa IP Address baik yang berada di internasional maupun yang berada di jaringan OpenIXP (NICE).

C:>tracert www.yahoo.com

Tracing route to www.yahoo-ht2.akadns.net
[209.131.36.158]
over a maximum of 30 hops:

1    <1 ms    <1 ms    <1 ms  192.168.1.1
2     1 ms    <1 ms    <1 ms  69.1.1.1
3   222 ms   223 ms   223 ms  157.130.195.13
4   222 ms   289 ms   222 ms  152.63.54.118
5   226 ms   242 ms  ^C

C:>tracert www.cbn.net.id

Tracing route to web.cbn.net.id [210.210.145.202]
over a maximum of 30 hops:

 1    <1 ms    <1 ms    <1 ms  192.168.1.1
 2     1 ms    <1 ms     1 ms  202.65.113.129
 3    11 ms    12 ms   127 ms  218.100.27.218
 4    21 ms    41 ms    21 ms  218.100.27.165
 5    22 ms    24 ms  ^C

Cara Mengetahui Identitas Pengirim Email

Anda pasti pernah mendapat email SPAM, HOAX, penipuan, undian berhadiah, berita bohong, dan Anda ingin tahu identitas pengirim email tersebut? Caranya mudah kok, yaitu dengan Email Trace. Anda bisa mengetahui IP-Adress pengirim email, peta di mana dia berada, derajat lintang dan busur, pokoknya lengkap deh. Caranya seperti ini:

1. Buka http://www.ip-adress.com/trace_email/

Di halaman tersebut Anda akan diminta memasukkan header email. Header email adalah informasi yang ada di setiap email, seperti IP Address pengirim & penerima.

Cara melihat header email:

* Yahoo Mail Baru: Klik kanan email, pilih View Full Headers

* Yahoo Mail Classic: Buka email tersebut, di bagian pojok kanan bawah ada tulisan View Full Header.

* Gmail / Google Mail: Buka email tersebut, di bagian atas ada pilihan Reply, samping tulisan Reply, ada tanda panah ke bawah, pilih Show Original.

* Hotmail: Klik kanan email, pilih View Source.

* Outlook Express: Buka email, buka menu File -> Properties -> Details -> Message Source

* micr*soft Outlook: Klik double email untuk melihat dalam full Window, buka menu Options -> View.

2. Copy-paste header email ke http://www.ip-adress.com/trace_email/ , klik Trace Email Sender

3. Selesai. Anda akan melihat informasi pengirim email seperti ini. Anda bisa mengklik whois untuk melihat lebih detail.

trace mengetahui identitas pengirim email image

Menghilangkan Password Administrator Windows XP

Untuk menghilangkan password windows XP jika user yang setara administrator kena password, tapi password administratornya sendiri tidak dipassword, maka caranya gampang saja, masuk ke Safe Mode (saya yakin pengguna komputer tahu cara masuk ke safe mode), masuk ke account administrator trus hilangkan password user dari situ.

Cara buat password (proteksi) file dokumen word dan excel 2003

Buat teman-teman yang masih pemula. Terkadang kita perlu memproteksi file (dokumen) word kita untuk menjaga agar file tersebut tidak diubah oleh orang lain. Secara default kita dapat memanfaatkan fasilitas proteksi dokumen yang telah disediakan oleh Microsoft Word.

Berikut cara membuat password file word:

1. Buka dokumen word yang akan diproteksi
2. Pada menu bar pilih Tools => Options..

Buat password word
3. Pada kotak dialog Options, pilih tab Security
a. Pada bagian password to open (masukkan password yang diinginkan)
b. Pada bagian password to modify (bisa diabaikan/dikosongkan jika anda tidak perlu memasukkan password pada saat akan melakukan modifikasi/ pengeditan)
c. Klik OK

Ketik password word4. Masukkan password yang telah diketik pada point 3

konfirmasi password word
5. Pada menu bar pilih File => save ( save as ) untuk menyimpan file

buka file word

6. Jika anda ingin memuka file tersebut anda harus memasukkan password, kotak dialog akan tampak seperti di bawah ini

Password saat buka file word

Membuat Password di Microsoft Word dan Excel 2007

Punya document rahasia di Microsoft Word atau Excelyang isinya nomor-nomor rekening yang berhasil dibobol,atau malah cerita tentang perselingkuhan dan……Lanjutkan aja sendiri.Ntar otak lu jadi kotor semua….Hahahaha.Daripada otak berpikiran yang gak jelas,mendingan ikuti aja cara-caranya step by step.

Setelah selesai membuat document dan sekarang waktunya untuk menyimpan kedalam folder atau drive yang diinginkan.Nah sekarang klik save as seperti gambar dibawah :

Setelah itu akan muncul gambar seperti ini.Perhatikan tanda panah,klik Tools >> General Options.

Selanjutnya akan muncul gambar seperti ini :

Isikan password yang diinginkan di kolom :
1.Password to Open :
2.Password to Modify
3.Klik Ok

Dan akan muncul konfirmasi ulang password yang sudah dimasukkan,seperti gambar ini :

Sekarang tinggal klik Save,dan silahkan buka document tadi.Bagaiman ? Sudah bisakan ? Lalu bagaiaman dengan Excel ? Kalau di Excel akan lebih mudah,Lihat gamabr :

Load Balancing Mikrotik

Kondisi : ISP dimana kita bekerja sebagai Administrator menggunakan lebih dari satu gateway untuk terhubung ke Internet. Semuanya harus dapat melayani layanan upstream & downstream. Karena akan beda kasusnya apabila salah satunya hanya dapat melayani downstream, contohnya jika menggunakan VSAT DVB One-way.
Untuk kasus ini dimisalkan ISP memiliki 2 jalur ke Internet. Satu menggunakan akses DSL (256 Kbps) dan lainnya menggunakan Wireless (512 Kbps). Dengan rasio pemakaian DSL:Wireless = 1:2 .

Yang akan dilakukan :

1. Menggunakan semua jalur gateway yang tersedia dengan teknik load-balancing.
2. Menjadikan salah satunya sebagai back-up dengan teknik fail-over.

OK, mari saja kita mulai eksperimennya :

1. IP address untuk akses ke LAN :
> /ip address add address=192.168.0.1/28 interface=LAN
IP address untuk akses ke jalur DSL :
> /ip address add address=10.32.57.253/29 interface=DSL
IP address untuk akses ke jalur Wireless :
> /ip address add address=10.9.8.2/29 interface=WIRELESS
Tentukan gateway dengan rasionya masing-masing :
> /ip route add gateway=10.32.57.254,10.9.8.1,10.9.8.1

2. Pada kasus untuk teknik fail-over. Diasumsikan jalur utama melalui Wireless dengan jalur DSL sebagai back-up apabila jalur utama tidak dapat dilalui. Untuk mengecek apakah jalur utama dapat dilalui atau tidak, digunakan command ping.
> /ip firewall mangle add chain=prerouting src-address=192.168.0.0/28 action=mark-routing new-routing-mark=SUBNET1-RM
> /ip route add gateway=10.9.8.1 routing-mark=SUBNET1-RM check-gateway=ping
> /ip route add gateway=10.32.57.254

3. Good Luck!!

=====================================================

sepertinya menggunakan mikrotik jg bisa untuk “load balancing” tinggal pasang 3 interface,

interface A untuk Speedy1 , misal IP 192.168.1.1
interface B untuk Speedy2 , misal IP 192.168.2.1
Interface C untuk LAN , misal IP 10.10.10.0/24

config di mikrotik sperti ini :

> /ip address add address=10.10.10.0/24 interface=LAN
IP address untuk SpeedyA :
> /ip address add address=192.168.1.1/32 interface=SpeedyA
IP address untuk SpeedyB :
> /ip address add address=192.168.2.1/32 interface=SpeedyB
Selanjutnya kita tentukan gateway dengan prioritas :
> /ip route add gateway=192.168.1.1,192.168.2.1,192.168.2.1

Bisa juga ditambahi config untuk failover, jd misal salahsatu speedy ada yg mati bisa langsung menggunakan speedy jalur satunya,

> /ip firewall mangle add chain=prerouting src-address=10.10.10.0/24 action=mark-routing new-routing-mark=RM-SPEEDY
> /ip route add gateway=192.168.2.1 routing-mark=rm-speedyB check-gateway=ping
> /ip route add gateway=192.168.1.1

Atau dg alternatif lainnya yakni, kita membagi traffik ke dua jalur speedy tersebut berdasarkan group network di LAN kita,

Kita setting IP di masing” interface mikrotik,

/ip address add address 192.168.1.1/32 interface speedyA
/ip address add address 192.168.2.1/32 interface speedyB
/ip address add address 10.10.10.1/24 interface LAN

Selanjutnya kita coba bagi network kedalam 2 Group

add chain=prerouting action=mark-connection src-address 10.10.10.0/25 new-routing-mark= Group-A
add chain=prerouting action=mark-connection src-address 10.10.10.128/25 new-routing-mark=Group-B

selanjutnya kita set default gateway masing-masing group

/ip route add gateway=192.168.1.1 routing-mark=Group-A
/ip route add gateway=192.168.2.1 routing-mark=Group-B

Pastikan juga kita udah setting NAT pada network kita

/ip firewall nat add chain=srcnat src-address 10.10.10.0/24 action=masquerade

=====================================================
Menggunakan 3 etrernet card

ether1 ==> wireless
ether2 ==> speedy
ethet3 ==> Lan

mikrotik command:
/ip address add address 202.152.74.1/32 interface ether1
/ip address add address 192.168.1.2/32 interface ether2
/ip address add address 192.168.10.1/24 interface ether3

Membagi Ip menjadi 2 Group

add chain=prerouting action=mark-connection src-address 192.168.10.0/25 new-routing-mark= Group-A
add chain=prerouting action=mark-connection src-address 192.168.10.128/25 new-routing-mark=Group-B

Default gw masing-masing Group

Group-A=192.168.10.0/25 default gw 192.168.1.1

Group-B=192.168.10.128/25 default gw 202.152.74.128

mikrotik command:

/ip route add gateway=192.168.1.1 routing-mark=Group-A
/ip route add gateway=202.152.74.128 routing-mark=Group-B

Nat ip local

192.168.10.0/24 ==>masquerade

mikrotik command:
/ip firewall nat add chain=srcnat src-address 192.168.10.0/24 action=masquerade

=====================================================
ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 check-gateway=ping
ip route add dst-address=0.0.0.0/0 gateway=10.0.148.254 check-gateway=ping

Dimana 192.168.1.1 router ADSL & 10.0.148.254 gateway RT/RW-net pake 2.4ghz dah cuma gitu aja sih ..
cek gateway pake ping jadi kalau gateway down
langsung switch. Kalau gak down ya langsung on 2 sekaligus, kayanya sih load balancing

cuma kebetulan saya tambah parameter distance=2 di gateway RT/RW-net jadi dapet prioritas lebih rendah ..

Firewall / NAT bikin dua biji untuk masing-masing gateway

untuk client sih gampang
add route default gw IP-ether-mikrotik

PC / Router mikrotik yang saya operasikan ada 3 LAN card
2 ke arah modem ADSL, 1 ke arah LAN
client di arahkan gatewaynya ke ethernet LAN mikrotik aja

Selamat mencoba dan Semoga sukses…. …

Follow

Get every new post delivered to your Inbox.